all repos — dotfiles @ 048c68b8fcf5609225e9c14b8904688b1bcd1412

my *nix dotfiles

nix/services/dunst.nix (view raw)

 1{ config
 2, pkgs
 3, theme
 4, ...
 5}:
 6
 7with theme;
 8{
 9  services.dunst = {
10    enable = true;
11    settings = {
12      global = {
13        font = "Input 12";
14        allow_markup = "no";
15        format = ''%s\n%b'';
16        sort = "yes";
17        indicate_hidden = "yes";
18        alignment = "right";
19        bounce_freq = "0";
20        show_age_threshold = "60";
21        word_wrap = "yes";
22        ignore_newline = "no";
23        geometry = "300x8-20+20";
24        shrink = "yes";
25        frame_width = 0;
26        transparency = "0";
27        idle_threshold = "120";
28        monitor = "0";
29        follow = "mouse";
30        sticky_history = "yes";
31        history_length = "20";
32        icon_folders = "/usr/share/icons/gnome/16x16/status/:/usr/share/icons/gnome/16x16/devices/";
33        show_indicators = "yes";
34        line_height = "0";
35        separator_height = "0";
36        padding = "20";
37        horizontal_padding = "20";
38        separator_color = "auto";
39        startup_notification = "false";
40        stack_duplicates = "true";
41        mouse_left_click = "close_current";
42        mouse_middle_click = "do_action, close_current";
43        mouse_right_click = "close_all";
44      };
45
46      urgency_normal = {
47        background = base07;
48        foreground = base00;
49        timeout = 10;
50      };
51
52      urgency_low = {
53        background = base07;
54        foreground = base00;
55        timeout = 2;
56      };
57
58      urgency_critical = {
59        background = base07;
60        foreground = base00;
61        timeout = 0;
62      };
63    };
64  };
65}