all repos — dotfiles @ 0521931fb5b8a18045e51d4d17d9c91f21a79a95

my *nix dotfiles

programs/firefox.nix (view raw)

 1{ config
 2, pkgs
 3, ...
 4}:
 5
 6
 7# XXX: Make sure to enable toolkit.legacyUserProfileCustomizations.stylesheets in about:config.
 8{
 9  programs.firefox = {
10    enable = true;
11    package = pkgs.wrapFirefox pkgs.firefox-unwrapped {
12      extraPolicies = {
13        ExtensionSettings = { };
14      };
15    };
16    profiles = {
17      icy = {
18        isDefault = true;
19        path = "34x366wc.default";
20        userChrome = ''
21          #sidebar-box[sidebarcommand="treestyletab_piro_sakura_ne_jp-sidebar-action"] #sidebar-header {
22            display: none;
23          }
24
25          #sidebar-header{ display: none }
26
27          #main-window[tabsintitlebar="true"]:not([extradragspace="true"]) #TabsToolbar > .toolbar-items {
28            opacity: 0;
29            pointer-events: none;
30          }
31          #main-window:not([tabsintitlebar="true"]) #TabsToolbar {
32              visibility: collapse !important;
33          }
34        '';
35      };
36    };
37  };
38}