all repos — dotfiles @ 07d6206fdf29236a876f821fac7b1dab81637fd1

my *nix dotfiles

nix/home.nix (view raw)

 1{ config
 2, pkgs
 3, self
 4, host
 5, ...
 6}:
 7
 8{
 9
10  imports = [
11    ./programs
12    ./services
13  ];
14
15  fonts.fontconfig.enable = true;
16
17  home.stateVersion = "master";
18  home.username = "icy";
19  home.homeDirectory = "/home/icy";
20  home.extraOutputsToInstall = [ "man" ];
21  home.packages = with pkgs; [
22
23    git
24    unzip
25    curl
26    tmux
27    weechat
28    ripgrep
29    imagemagick
30    ffmpeg
31    wget
32    tree
33    mpv
34    noto-fonts-cjk
35    noto-fonts-emoji
36    jq
37    yq-go
38    fzy
39    kubectl
40    slack
41    nixpkgs-fmt
42    libnotify
43    signal-desktop
44    calibre
45    pinentry
46    kontact
47    korganizer
48    kmail
49    libreoffice-qt
50    akonadi
51
52  ] ++ (import ./bin { inherit pkgs host; });
53
54  xdg = {
55    userDirs = {
56      enable = true;
57      desktop = "\$HOME/desktop";
58      documents = "\$HOME/docs";
59      download = "\$HOME/downloads";
60      pictures = "\$HOME/pics";
61      videos = "\$HOME/vids";
62    };
63  };
64}
65