programs/alacritty.nix (view raw)
1{ config
2, pkgs
3, lib
4, ...
5}:
6let
7 isDarwin = lib.strings.hasSuffix "darwin" pkgs.stdenv.hostPlatform.system;
8
9 fontConfig =
10 if isDarwin then {
11 normal = { family = "SF Mono"; style = "Light"; };
12 bold = { family = "SF Mono"; style = "Semibold"; };
13 italic = { family = "SF Mono"; style = "Light Italic"; };
14 size = 15.0;
15 offset.y = 5;
16 }
17 else {
18 normal = "Input";
19 size = 12.0;
20 };
21in
22{
23 programs.alacritty = {
24 enable = true;
25 settings = {
26 window = {
27 padding.x = 10;
28 padding.y = 10;
29 dynamic_padding = true;
30 decorations = "None";
31 startup_mode = "Maximized";
32
33
34 option_as_alt = "OnlyLeft";
35 };
36
37 font = fontConfig;
38 cursor.style = "Beam";
39
40
41 colors = {
42 primary = {
43 background = "0xf4f4f4";
44 foreground = "0x676767";
45 };
46 normal = {
47 black = "0xf4f4f4";
48 red = "0xdb7070";
49 green = "0x7c9f4b";
50 yellow = "0xd69822";
51 blue = "0x6587bf";
52 magenta = "0xb870ce";
53 cyan = "0x509c93";
54 white = "0x676767";
55 };
56 bright = {
57 black = "0xaaaaaa";
58 red = "0xc66666";
59 green = "0x6d8b42";
60 yellow = "0xe7e7e7";
61 blue = "0x8a8a8a";
62 magenta = "0xa262b5";
63 cyan = "0x43827b";
64 white = "0x525252";
65 };
66 };
67
68 };
69 };
70}