programs/ssh.nix (view raw)
1{ config
2, pkgs
3, ...
4}:
5
6{
7 programs.ssh = {
8 enable = true;
9 matchBlocks = {
10 "*" = {
11 serverAliveInterval = 180;
12 serverAliveCountMax = 3;
13 };
14 "github.com" = {
15 user = "git";
16 hostname = "github.com";
17 identityFile = [ "~/.ssh/id_ed25519" "~/.ssh/upcloud" ];
18 };
19 "fern" = {
20 user = "ubuntu";
21 hostname = "fern";
22 identityFile = "~/.ssh/id_rsa";
23 };
24 "egg" = {
25 user = "icy";
26 hostname = "egg";
27 identityFile = [ "~/.ssh/id_ed25519" "~/.ssh/upcloud" ];
28 };
29 "upcloud" = {
30 hostname = "git.services.upcloud.com";
31 identityFile = "~/.ssh/upcloud";
32 };
33 "denna" = {
34 hostname = "denna";
35 identityFile = [ "~/.ssh/id_ed25519" "~/.ssh/upcloud" ];
36 };
37 "jade" = {
38 user = "ubuntu";
39 hostname = "jade";
40 identityFile = "~/.ssh/id_rsa";
41 };
42 "lapis2" = {
43 user = "icy";
44 hostname = "150.230.131.193";
45 identityFile = "~/.ssh/id_rsa";
46 };
47 "aniverse" = {
48 user = "icy";
49 hostname = "94.237.18.93";
50 identityFile = "~/.ssh/id_ed25519";
51 };
52 };
53 };
54}