nix/programs/firefox.nix (view raw)
1{ config
2, pkgs
3, ...
4}:
5
6{
7 programs.firefox = {
8 enable = true;
9 profiles = {
10 icy = {
11 isDefault = true;
12 path = "34x366wc.default";
13 userChrome = ''
14 #sidebar-box[sidebarcommand="treestyletab_piro_sakura_ne_jp-sidebar-action"] #sidebar-header {
15 display: none;
16 }
17
18 #main-window[tabsintitlebar="true"]:not([extradragspace="true"]) #TabsToolbar > .toolbar-items {
19 opacity: 0;
20 pointer-events: none;
21 }
22 #main-window:not([tabsintitlebar="true"]) #TabsToolbar {
23 visibility: collapse !important;
24 }
25 '';
26 };
27 };
28 };
29}