all repos — dotfiles @ 2cbf49bedf571e35822a4d2c73d2cb275657cddd

my *nix dotfiles

nix/programs/common.nix (view raw)

 1{ config
 2, pkgs
 3, self
 4, ...
 5}:
 6
 7{
 8
 9  imports = [
10    ./git.nix
11    ./tmux.nix
12    ./readline.nix
13    ./neovim.nix
14    ./bash.nix
15  ];
16
17  programs = {
18    home-manager.enable = true;
19    direnv = {
20      enable = true;
21      enableBashIntegration = true;
22      nix-direnv = {
23        enable = true;
24      };
25    };
26    zoxide = {
27      enable = true;
28      enableBashIntegration = true;
29    };
30    htop = {
31      enable = true;
32      settings.color_scheme = 1;
33    };
34  };
35}