nix/programs/git.nix (view raw)
1{ config
2, pkgs
3, theme
4, ...
5}:
6
7with theme;
8{
9 programs.git = {
10 enable = true;
11 ignores = [ ".envrc" ];
12 userEmail = "x@icyphox.sh";
13 userName = "Anirudh Oppiliappan";
14 signing = {
15 key = "8A93F96F78C5D4C4";
16 signByDefault = true;
17 };
18 extraConfig = {
19 commit.verbose = true;
20 init.defaultBranch = "master";
21 pull.rebase = "true";
22 };
23 };
24}