all repos — dotfiles @ 3babd1e0f672799c603fc65323c7cca799ea111e

my *nix dotfiles

nix/home.nix (view raw)

 1{ config
 2, pkgs
 3, self
 4, host
 5, ...
 6}:
 7
 8{
 9
10  imports = [
11    ./programs
12    ./services
13  ];
14
15  fonts.fontconfig.enable = true;
16
17  home.stateVersion = "22.11";
18  home.username = "icy";
19  home.homeDirectory = "/home/icy";
20  home.extraOutputsToInstall = [ "man" ];
21  home.packages = with pkgs; [
22
23    git
24    unzip
25    curl
26    tmux
27    ripgrep
28    imagemagick
29    ffmpeg
30    wget
31    tree
32    mpv
33    noto-fonts-cjk
34    noto-fonts-emoji
35    jq
36    yq-go
37    fzy
38    slack
39    nixpkgs-fmt
40    libnotify
41    signal-desktop
42    calibre
43    pinentry
44    kontact
45    korganizer
46    libreoffice-qt
47    akonadi
48    go
49    evolution
50    dconf
51
52  ]; # ++ (import ./bin { inherit pkgs host; });
53
54  gtk = {
55    enable = true;
56    iconTheme = {
57      package = pkgs.breeze-icons;
58      name = "Breeze";
59    };
60    theme = {
61      package = pkgs.breeze-gtk;
62      name = "Breeze";
63    };
64  };
65
66  xdg = {
67    userDirs = {
68      enable = true;
69      desktop = "\$HOME/desktop";
70      documents = "\$HOME/docs";
71      download = "\$HOME/downloads";
72      pictures = "\$HOME/pics";
73      videos = "\$HOME/vids";
74    };
75  };
76}
77