all repos — dotfiles @ 3e5310b97fbff6540545635654397c1aef286a97

my *nix dotfiles

nix/programs/git.nix (view raw)

 1{ config
 2, pkgs
 3, ...
 4}:
 5
 6{
 7  programs.git = {
 8    enable = true;
 9    ignores = [ ".envrc" ];
10    userEmail = "x@icyphox.sh";
11    userName = "Anirudh Oppiliappan";
12    signing = {
13      key = "8A93F96F78C5D4C4";
14      signByDefault = true;
15    };
16    extraConfig = {
17      commit.verbose = true;
18      init.defaultBranch = "master";
19      pull.rebase = "true";
20    };
21    includes = [
22      {
23        "path" = "~/code/upcloud/gitconfig";
24        "condition" = "gitdir:~/code/upcloud/";
25      }
26    ];
27  };
28}