all repos — dotfiles @ 401b967128683a263b5a6cae4f572be66548d5ad

my *nix dotfiles

programs/alacritty.nix (view raw)

 1{ config
 2, pkgs
 3, lib
 4, ...
 5}:
 6let
 7  isDarwin = lib.strings.hasSuffix "darwin" pkgs.stdenv.hostPlatform.system;
 8
 9  fontConfig =
10    if isDarwin then {
11      normal = { family = "SF Mono"; style = "Light"; };
12      bold = { family = "SF Mono"; style = "Semibold"; };
13      italic = { family = "SF Mono"; style = "Light Italic"; };
14      size = 15.0;
15      offset.y = 10;
16    }
17    else {
18      normal = { family = "Input"; style = "Regular"; };
19      bold = { family = "Input"; style = "Bold"; };
20      italic = { family = "Input"; style = "Italic"; };
21      size = 12.0;
22      offset.y = 10;
23    };
24in
25{
26  programs.alacritty = {
27    enable = true;
28    settings = {
29      env = {
30        TERM = "xterm-256color";
31      };
32      window = {
33        padding.x = 10;
34        padding.y = 10;
35        dynamic_padding = true;
36        decorations = "None";
37        startup_mode = "Maximized";
38
39
40        option_as_alt = "OnlyLeft";
41      };
42
43      font = fontConfig;
44      cursor.style = "Beam";
45
46
47      colors = {
48        primary = {
49          background = "0xf4f4f4";
50          foreground = "0x676767";
51        };
52        normal = {
53          black = "0xf4f4f4";
54          red = "0xdb7070";
55          green = "0x7c9f4b";
56          yellow = "0xd69822";
57          blue = "0x6587bf";
58          magenta = "0xb870ce";
59          cyan = "0x509c93";
60          white = "0x676767";
61        };
62        bright = {
63          black = "0xaaaaaa";
64          red = "0xc66666";
65          green = "0x6d8b42";
66          yellow = "0xe7e7e7";
67          blue = "0x8a8a8a";
68          magenta = "0xa262b5";
69          cyan = "0x43827b";
70          white = "0x525252";
71        };
72      };
73
74    };
75  };
76}