all repos — dotfiles @ 43677713e127effe34b83d4dbc16229a3aa8381e

my *nix dotfiles

hosts/denna/configuration.nix (view raw)

 1{ config, pkgs, ... }:
 2
 3{
 4  imports =
 5    [
 6      ./hardware-configuration.nix
 7    ];
 8
 9  boot.loader.systemd-boot.enable = true;
10  boot.loader.efi.canTouchEfiVariables = true;
11
12  boot.initrd.luks.devices."luks-0ae4be28-55a1-4a0c-8518-c6d53540cb26".device = "/dev/disk/by-uuid/0ae4be28-55a1-4a0c-8518-c6d53540cb26";
13  networking.hostName = "denna"; # Define your hostname.
14
15  networking.networkmanager.enable = true;
16
17  time.timeZone = "Europe/Helsinki";
18
19  i18n.defaultLocale = "en_US.UTF-8";
20
21  i18n.extraLocaleSettings = {
22    LC_ADDRESS = "fi_FI.UTF-8";
23    LC_IDENTIFICATION = "fi_FI.UTF-8";
24    LC_MEASUREMENT = "fi_FI.UTF-8";
25    LC_MONETARY = "fi_FI.UTF-8";
26    LC_NAME = "fi_FI.UTF-8";
27    LC_NUMERIC = "fi_FI.UTF-8";
28    LC_PAPER = "fi_FI.UTF-8";
29    LC_TELEPHONE = "fi_FI.UTF-8";
30    LC_TIME = "fi_FI.UTF-8";
31  };
32
33  users.users.icy = {
34    isNormalUser = true;
35    description = "icy";
36    extraGroups = [ "networkmanager" "wheel" ];
37    packages = with pkgs; [ ];
38  };
39
40  # Allow unfree packages
41  nixpkgs.config.allowUnfree = true;
42
43  # List packages installed in system profile. To search, run:
44  # $ nix search wget
45  environment.systemPackages = with pkgs; [
46    vim
47    wget
48    git
49  ];
50
51  services = {
52    openssh.enable = true;
53    tailscale.enable = true;
54  };
55
56  services.radicale = {
57    enable = true;
58    settings = {
59      server = {
60        hosts = [ "127.0.0.1:5232" ];
61      };
62      auth = {
63        type = "htpasswd";
64        htpasswd = "/var/svc/radicale/users";
65        htpasswd_encryption = "bcrypt";
66      };
67      storage = {
68        filesystem_folder = "/var/svc/radicale/collections";
69      };
70    };
71  };
72
73  nix.settings.experimental-features = [ "nix-command" "flakes" ];
74  system.stateVersion = "24.05"; # Did you read the comment?
75
76}
77