programs/alacritty.nix (view raw)
1{ config
2, pkgs
3, lib
4, ...
5}:
6let
7 isDarwin = lib.strings.hasSuffix "darwin" pkgs.stdenv.hostPlatform.system;
8
9 fontConfig =
10 if isDarwin then {
11 normal.family = "SF Mono";
12 bold = { family = "SF Mono"; style = "Semibold"; };
13 size = 15.0;
14 offset.y = 5;
15 }
16 else {
17 normal = "Input";
18 size = 12.0;
19 };
20in
21{
22 programs.alacritty = {
23 enable = true;
24 settings = {
25 env = {
26 "TERM" = "xterm-256color-italic";
27 };
28
29 window = {
30 padding.x = 10;
31 padding.y = 10;
32 dynamic_padding = true;
33 decorations = "None";
34 startup_mode = "Maximized";
35
36
37 option_as_alt = "OnlyLeft";
38 };
39
40 font = fontConfig;
41 cursor.style = "Beam";
42
43
44 colors = {
45 primary = {
46 background = "0xf4f4f4";
47 foreground = "0x676767";
48 };
49 normal = {
50 black = "0xf4f4f4";
51 red = "0xdb7070";
52 green = "0x7c9f4b";
53 yellow = "0xd69822";
54 blue = "0x6587bf";
55 magenta = "0xb870ce";
56 cyan = "0x509c93";
57 white = "0x676767";
58 };
59 bright = {
60 black = "0xaaaaaa";
61 red = "0xc66666";
62 green = "0x6d8b42";
63 yellow = "0xe7e7e7";
64 blue = "0x8a8a8a";
65 magenta = "0xa262b5";
66 cyan = "0x43827b";
67 white = "0x525252";
68 };
69 };
70
71 };
72 };
73}