nix/home.nix (view raw)
1{ config
2, pkgs
3, theme
4, self
5, host
6, ...
7}:
8
9{
10
11 imports = [
12 ./programs
13 ./services
14 ./x
15 ./mail.nix
16 ];
17
18 home.stateVersion = "22.05";
19 home.username = "icy";
20 home.homeDirectory = "/home/icy";
21 home.extraOutputsToInstall = [ "man" ];
22 home.packages = with pkgs; [
23
24 git
25 unzip
26 curl
27 tmux
28 weechat
29 xclip
30 ripgrep
31 arandr
32 imagemagick
33 ffmpeg
34 wget
35 tree
36 mpv
37 w3m
38 noto-fonts-emoji
39 jq
40 yq-go
41 sxiv
42 feh
43 st
44 fzy
45 xorg.xmodmap
46 kubectl
47 slack
48 nixpkgs-fmt
49 libnotify
50 signal-desktop
51 aerc
52 calibre
53 pinentry
54
55 ] ++ (import ./bin { inherit pkgs theme host; });
56
57 xdg = {
58 userDirs = {
59 enable = true;
60 desktop = "\$HOME/desktop";
61 documents = "\$HOME/docs";
62 download = "\$HOME/downloads";
63 pictures = "\$HOME/pics";
64 videos = "\$HOME/vids";
65 };
66 };
67}
68