all repos — dotfiles @ 5674e47702a2c2b46d9df9ed4e363a61522b4cd3

my *nix dotfiles

hosts/wyndle/hardware-configuration.nix (view raw)

 1# Do not modify this file!  It was generated by ‘nixos-generate-config’
 2# and may be overwritten by future invocations.  Please make changes
 3# to /etc/nixos/configuration.nix instead.
 4{ config, lib, pkgs, modulesPath, ... }:
 5
 6{
 7  imports =
 8    [
 9      (modulesPath + "/installer/scan/not-detected.nix")
10    ];
11
12  boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "usbhid" "usb_storage" "sd_mod" ];
13  boot.initrd.kernelModules = [ ];
14  boot.kernelModules = [ "kvm-amd" ];
15  boot.extraModulePackages = [ ];
16
17  fileSystems."/" =
18    {
19      device = "/dev/disk/by-uuid/f66408c3-50c9-421a-80c1-8163761f3817";
20      fsType = "ext4";
21    };
22
23  fileSystems."/boot" =
24    {
25      device = "/dev/disk/by-uuid/E85D-EAD8";
26      fsType = "vfat";
27    };
28
29  swapDevices = [ ];
30
31  hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
32  hardware.opengl.enable = true;
33  hardware.nvidia.modesetting.enable = false;
34  hardware.pulseaudio.enable = false;
35}