all repos — dotfiles @ 5eaaeb587f719a05f884269327a60035a11db477

my *nix dotfiles

nix/home.nix (view raw)

 1{ config
 2, pkgs
 3, theme
 4, self
 5, ...
 6}:
 7
 8{
 9
10  imports = [
11    ./programs
12    ./services
13    ./x
14    ./mail.nix
15  ];
16
17  home.stateVersion = "21.05";
18  home.username = "icy";
19  home.homeDirectory = "/home/icy";
20  home.extraOutputsToInstall = [ "man" ];
21  home.packages = with pkgs; [
22
23    git
24    unzip
25    curl
26    tmux
27    weechat
28    xclip
29    ripgrep
30    arandr
31    imagemagick
32    ffmpeg
33    wget
34    tree
35    mpv
36    w3m
37    noto-fonts-emoji
38    jq
39    yq
40    sxiv
41    feh
42    st
43    fzy
44    xorg.xmodmap
45    kubectl
46    slack
47    nixpkgs-fmt
48    libnotify
49    signal-desktop
50    aerc
51    calibre
52
53  ] ++ (import ./bin { inherit pkgs theme; });
54
55  xdg = {
56    userDirs = {
57      enable = true;
58      desktop = "\$HOME/desktop";
59      documents = "\$HOME/docs";
60      download = "\$HOME/downloads";
61      pictures = "\$HOME/pics";
62      videos = "\$HOME/vids";
63    };
64  };
65
66  xsession = {
67    enable = true;
68    windowManager.command = "cwm";
69    initExtra = ''
70      xrdb -load $HOME/.Xresources
71      xmodmap $HOME/.xmodmap
72      bar &
73    '';
74  };
75
76}