all repos — dotfiles @ 5eaaeb587f719a05f884269327a60035a11db477

my *nix dotfiles

nix/programs/neovim.nix (view raw)

 1{ config
 2, pkgs
 3, self
 4, ...
 5}:
 6
 7{
 8  programs.neovim = {
 9    enable = true;
10    withNodeJs = false;
11    vimAlias = true;
12    withPython3 = true;
13    extraPackages = with pkgs; [
14      gotools
15      gopls
16      go
17    ];
18    extraConfig = ''
19      runtime _init.lua
20    '';
21    plugins = with pkgs.vimPlugins; [
22      nvim-lspconfig
23      (nvim-treesitter.withPlugins (_: pkgs.tree-sitter.allGrammars))
24      coq_nvim
25      playground
26      vim-surround
27      targets-vim
28      vim-gitgutter
29      vim-rsi
30      vim-jsonnet
31    ];
32  };
33}