all repos — dotfiles @ 6d79b364fff07095f838185c6c4abbf9941a4ee6

my *nix dotfiles

programs/ssh.nix (view raw)

 1{ config
 2, pkgs
 3, ...
 4}:
 5
 6{
 7  programs.ssh = {
 8    enable = true;
 9    matchBlocks = {
10      "*" = {
11        serverAliveInterval = 180;
12        serverAliveCountMax = 3;
13        identityFile = [ "~/.ssh/id_ed25519" "~/.ssh/upcloud" ];
14      };
15      "github.com" = {
16        user = "git";
17        hostname = "github.com";
18      };
19    };
20  };
21}