all repos — dotfiles @ 6df9b75dd6860e4e6075b6e0d19154bfeb229a00

my *nix dotfiles

programs/git.nix (view raw)

 1{ config
 2, pkgs
 3, ...
 4}:
 5
 6{
 7  programs.git = {
 8    enable = true;
 9    ignores = [ ".envrc" ];
10    userEmail = "x@icyphox.sh";
11    userName = "Anirudh Oppiliappan";
12    signing = {
13      key = "8A93F96F78C5D4C4";
14      signByDefault = true;
15    };
16    extraConfig = {
17      commit.verbose = true;
18      init.defaultBranch = "master";
19      pull.rebase = "true";
20
21      url."ssh://git@github.com/".insteadOf = "https://github.com/";
22      url."ssh://git@git.services.upcloud.com/".insteadOf = "https://git.services.upcloud.com/";
23    };
24    includes = [
25      {
26        "path" = "~/code/upcloud/gitconfig";
27        "condition" = "gitdir:~/code/upcloud/";
28      }
29    ];
30  };
31}