nix/home.nix (view raw)
1{ config
2, pkgs
3, self
4, host
5, ...
6}:
7
8{
9
10 imports = [
11 ./programs
12 ./services
13 ];
14
15 fonts.fontconfig.enable = true;
16
17 # XXX: remove this
18 manual.manpages.enable = false;
19
20 home.stateVersion = "22.05";
21 home.username = "icy";
22 home.homeDirectory = "/home/icy";
23 home.extraOutputsToInstall = [ "man" ];
24 home.packages = with pkgs; [
25
26 git
27 unzip
28 curl
29 tmux
30 weechat
31 ripgrep
32 imagemagick
33 ffmpeg
34 wget
35 tree
36 mpv
37 noto-fonts-cjk
38 noto-fonts-emoji
39 jq
40 yq-go
41 fzy
42 kubectl
43 slack
44 nixpkgs-fmt
45 libnotify
46 signal-desktop
47 calibre
48 pinentry
49 kontact
50 korganizer
51 kmail
52 libreoffice-qt
53 akonadi
54
55 ] ++ (import ./bin { inherit pkgs host; });
56
57 xdg = {
58 userDirs = {
59 enable = true;
60 desktop = "\$HOME/desktop";
61 documents = "\$HOME/docs";
62 download = "\$HOME/downloads";
63 pictures = "\$HOME/pics";
64 videos = "\$HOME/vids";
65 };
66 };
67}
68