programs/common.nix (view raw)
1{ config
2, pkgs
3, self
4, ...
5}:
6
7{
8
9 imports = [
10 ./git.nix
11 ./tmux.nix
12 ./readline.nix
13 ./neovim.nix
14 ./bash.nix
15 ./ssh.nix
16 ./alacritty.nix
17 ./fish.nix
18 ./zed/default.nix
19 ];
20
21 programs = {
22 home-manager.enable = true;
23 direnv = {
24 enable = true;
25 enableBashIntegration = true;
26 nix-direnv = {
27 enable = true;
28 };
29 };
30 zoxide = {
31 enable = true;
32 enableBashIntegration = true;
33 };
34 htop = {
35 enable = true;
36 settings.color_scheme = 1;
37 };
38 };
39}