programs/git.nix (view raw)
1{ config
2, pkgs
3, ...
4}:
5
6{
7 programs.git = {
8 enable = true;
9 ignores = [ ".envrc" ];
10 userEmail = "x@icyphox.sh";
11 userName = "Anirudh Oppiliappan";
12 extraConfig = {
13 commit.verbose = true;
14 init.defaultBranch = "master";
15 pull.rebase = "true";
16 gpg.format = "ssh";
17 user.signingkey = "~/.ssh/id_ed25519.pub";
18
19 url."ssh://git@github.com/".insteadOf = "https://github.com/";
20 url."ssh://git@git.services.upcloud.com/".insteadOf = "https://git.services.upcloud.com/";
21 };
22 includes = [
23 {
24 "path" = "~/code/upcloud/gitconfig";
25 "condition" = "gitdir:~/code/upcloud/";
26 }
27 ];
28 };
29}