nix/mail.nix (view raw)
1{ config
2, lib
3, pkgs
4, ...
5}:
6
7{
8 accounts.email.maildirBasePath = "mail";
9 accounts.email.accounts."x@icyphox.sh" = {
10 address = "x@icyphox.sh";
11 imap = {
12 host = "imap.migadu.com";
13 port = 993;
14 };
15 maildir = {
16 path = "personal";
17 };
18 mbsync = {
19 enable = true;
20 create = "maildir";
21 expunge = "maildir";
22 };
23 primary = true;
24 passwordCommand = "${pkgs.gnupg}/bin/gpg -q --for-your-eyes-only --no-tty -d /home/icy/.pw/default.gpg";
25 realName = "Anirudh Oppiliappan";
26 userName = "x@icyphox.sh";
27 signature = {
28 text = ''
29
30 --
31 Anirudh Oppiliappan
32 https://icyphox.sh
33 '';
34 };
35 };
36}
37