hosts/sini/hardware-configuration.nix (view raw)
1# Do not modify this file! It was generated by ‘nixos-generate-config’
2# and may be overwritten by future invocations. Please make changes
3# to /etc/nixos/configuration.nix instead.
4{ config, lib, pkgs, modulesPath, ... }:
5
6{
7 imports =
8 [
9 (modulesPath + "/installer/scan/not-detected.nix")
10 ];
11
12 boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "usbhid" "usb_storage" "sd_mod" ];
13 boot.initrd.kernelModules = [ ];
14 boot.kernelModules = [ "kvm-intel" ];
15 boot.extraModulePackages = [ ];
16
17 fileSystems."/" =
18 {
19 device = "/dev/disk/by-uuid/16a54d44-96ca-4b94-b4b5-66c5964fdbf5";
20 fsType = "ext4";
21 };
22
23 boot.initrd.luks.devices."luks-bbed123c-7bda-4d76-9d39-a47b3452ab55".device = "/dev/disk/by-uuid/bbed123c-7bda-4d76-9d39-a47b3452ab55";
24
25 fileSystems."/boot" =
26 {
27 device = "/dev/disk/by-uuid/4246-3555";
28 fsType = "vfat";
29 options = [ "fmask=0022" "dmask=0022" ];
30 };
31
32 swapDevices =
33 [{ device = "/dev/disk/by-uuid/f812a558-7d9a-4dbd-a343-2f556156832f"; }];
34
35 # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
36 # (the default) this is the recommended approach. When using systemd-networkd it's
37 # still possible to use this option, but it's recommended to use it in conjunction
38 # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
39 networking.useDHCP = lib.mkDefault true;
40 # networking.interfaces.enp2s0.useDHCP = lib.mkDefault true;
41 # networking.interfaces.wlp3s0.useDHCP = lib.mkDefault true;
42
43 nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
44 hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
45}
46