all repos — dotfiles @ b014e77ebaf6a6fc8b4e8850e59379a8be302ca3

my *nix dotfiles

nix/hosts/lapis/hardware-configuration.nix (view raw)

 1# Do not modify this file!  It was generated by ‘nixos-generate-config’
 2# and may be overwritten by future invocations.  Please make changes
 3# to /etc/nixos/configuration.nix instead.
 4{ config, lib, pkgs, modulesPath, ... }:
 5
 6{
 7  imports =
 8    [
 9      (modulesPath + "/installer/scan/not-detected.nix")
10    ];
11
12  boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "nvme" "usb_storage" "sd_mod" "alcor" ];
13  boot.initrd.kernelModules = [ ];
14  boot.kernelModules = [ "kvm-intel" ];
15  boot.extraModulePackages = [ ];
16
17  fileSystems."/" =
18    {
19      device = "/dev/disk/by-uuid/9b7ae4a9-de63-4972-95d1-d7e5cd63b558";
20      fsType = "ext4";
21    };
22
23  fileSystems."/boot" =
24    {
25      device = "/dev/disk/by-uuid/5780-2835";
26      fsType = "vfat";
27    };
28
29  swapDevices =
30    [{ device = "/dev/disk/by-uuid/1511c1d3-764f-471e-9468-db26bf752020"; }];
31
32  powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
33  hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
34}