nix/home.nix (view raw)
1{ config
2, pkgs
3, self
4, host
5, ...
6}:
7
8{
9
10 imports = [
11 ./programs
12 ./services
13 ];
14
15 home.stateVersion = "22.05";
16 home.username = "icy";
17 home.homeDirectory = "/home/icy";
18 home.extraOutputsToInstall = [ "man" ];
19 home.packages = with pkgs; [
20
21 git
22 unzip
23 curl
24 tmux
25 weechat
26 ripgrep
27 imagemagick
28 ffmpeg
29 wget
30 tree
31 mpv
32 noto-fonts-emoji
33 jq
34 yq-go
35 fzy
36 kubectl
37 slack
38 nixpkgs-fmt
39 libnotify
40 signal-desktop
41 calibre
42 pinentry
43 kontact
44 trojita
45 korganizer
46 libreoffice-qt
47
48 ] ++ (import ./bin { inherit pkgs host; });
49
50 xdg = {
51 userDirs = {
52 enable = true;
53 desktop = "\$HOME/desktop";
54 documents = "\$HOME/docs";
55 download = "\$HOME/downloads";
56 pictures = "\$HOME/pics";
57 videos = "\$HOME/vids";
58 };
59 };
60}
61