nix/programs/firefox.nix (view raw)
1{ config
2, pkgs
3, ...
4}:
5
6
7# XXX: Make sure to enable toolkit.legacyUserProfileCustomizations.stylesheets in about:config.
8{
9 programs.firefox = {
10 enable = true;
11 package = pkgs.wrapFirefox pkgs.firefox-unwrapped {
12 forceWayland = true;
13 extraPolicies = {
14 ExtensionSettings = { };
15 };
16 };
17 profiles = {
18 icy = {
19 isDefault = true;
20 path = "34x366wc.default";
21 userChrome = ''
22 #sidebar-box[sidebarcommand="treestyletab_piro_sakura_ne_jp-sidebar-action"] #sidebar-header {
23 display: none;
24 }
25
26 #main-window[tabsintitlebar="true"]:not([extradragspace="true"]) #TabsToolbar > .toolbar-items {
27 opacity: 0;
28 pointer-events: none;
29 }
30 #main-window:not([tabsintitlebar="true"]) #TabsToolbar {
31 visibility: collapse !important;
32 }
33 '';
34 };
35 };
36 };
37}