all repos — dotfiles @ ba9198071452e26eb6f620dcee69246a152059d2

my *nix dotfiles

nix/hosts/lapis/hardware-configuration.nix (view raw)

 1# Do not modify this file!  It was generated by ‘nixos-generate-config’
 2# and may be overwritten by future invocations.  Please make changes
 3# to /etc/nixos/configuration.nix instead.
 4{ config, lib, pkgs, modulesPath, ... }:
 5
 6{
 7  imports =
 8    [ (modulesPath + "/installer/scan/not-detected.nix")
 9    ];
10
11  boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "nvme" "usb_storage" "sd_mod" "alcor" ];
12  boot.initrd.kernelModules = [ ];
13  boot.kernelModules = [ "kvm-intel" ];
14  boot.extraModulePackages = [ ];
15
16  fileSystems."/" =
17    { device = "/dev/disk/by-uuid/11f7daf9-77b9-48ec-990a-37f4d4889337";
18      fsType = "ext4";
19    };
20
21  fileSystems."/boot" =
22    { device = "/dev/disk/by-uuid/DD92-FE3F";
23      fsType = "vfat";
24    };
25
26  swapDevices =
27    [ { device = "/dev/disk/by-uuid/74e12c57-0f34-4faa-983f-212a8172b2ae"; }
28    ];
29
30  powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
31  hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
32}