all repos — dotfiles @ c4037106d723b0b3e78fc94a18c824197058a5e0

my *nix dotfiles

nix/programs/neovim.nix (view raw)

 1{ config
 2, pkgs
 3, self
 4, ...
 5}:
 6
 7{
 8  programs.neovim = {
 9    enable = true;
10    withNodeJs = false;
11    vimAlias = true;
12    withPython3 = true;
13    extraPackages = with pkgs; [
14      gotools
15      gopls
16      go
17      nodePackages.vscode-langservers-extracted
18      sumneko-lua-language-server
19    ];
20    extraConfig = ''
21      runtime _init.lua
22    '';
23    plugins = with pkgs.vimPlugins; [
24      nvim-lspconfig
25      (nvim-treesitter.withPlugins (_: pkgs.tree-sitter.allGrammars))
26      coq_nvim
27      playground
28      vim-surround
29      targets-vim
30      vim-gitgutter
31      vim-rsi
32      # nvim-treesitter-textobjects
33    ];
34  };
35}