nix/programs/firefox.nix (view raw)
1{ config
2, pkgs
3, ...
4}:
5
6
7# XXX: Make sure to enable toolkit.legacyUserProfileCustomizations.stylesheets in about:config.
8{
9 programs.firefox = {
10 enable = true;
11 profiles = {
12 icy = {
13 isDefault = true;
14 path = "34x366wc.default";
15 userChrome = ''
16 #sidebar-box[sidebarcommand="treestyletab_piro_sakura_ne_jp-sidebar-action"] #sidebar-header {
17 display: none;
18 }
19
20 #main-window[tabsintitlebar="true"]:not([extradragspace="true"]) #TabsToolbar > .toolbar-items {
21 opacity: 0;
22 pointer-events: none;
23 }
24 #main-window:not([tabsintitlebar="true"]) #TabsToolbar {
25 visibility: collapse !important;
26 }
27 '';
28 };
29 };
30 };
31}