all repos — dotfiles @ d50e42615b05e5b3d1263b257bee841e2043c822

my *nix dotfiles

programs/common.nix (view raw)

 1{ config
 2, pkgs
 3, self
 4, ...
 5}:
 6
 7{
 8
 9  imports = [
10    ./git.nix
11    ./tmux.nix
12    ./readline.nix
13    ./neovim.nix
14    ./bash.nix
15    ./ssh.nix
16    ./alacritty.nix
17    ./fish.nix
18  ];
19
20  programs = {
21    home-manager.enable = true;
22    direnv = {
23      enable = true;
24      enableBashIntegration = true;
25      nix-direnv = {
26        enable = true;
27      };
28    };
29    zoxide = {
30      enable = true;
31      enableBashIntegration = true;
32    };
33    htop = {
34      enable = true;
35      settings.color_scheme = 1;
36    };
37  };
38}