all repos — dotfiles @ df4f1038a6a0e9e406776296665d816e8285acac

my *nix dotfiles

programs/alacritty.nix (view raw)

 1{ config
 2, pkgs
 3, lib
 4, ...
 5}:
 6let
 7  isDarwin = lib.strings.hasSuffix "darwin" pkgs.stdenv.hostPlatform.system;
 8
 9  fontConfig =
10    if isDarwin then {
11      normal.family = "SF Mono";
12      bold = { family = "SF Mono"; style = "Semibold"; };
13      size = 15.0;
14      offset.y = 5;
15    }
16    else {
17      normal = "Input";
18      size = 12.0;
19    };
20in
21{
22  programs.alacritty = {
23    enable = true;
24    settings = {
25      window = {
26        padding.x = 10;
27        padding.y = 10;
28        dynamic_padding = true;
29        decorations = "None";
30        startup_mode = "Maximized";
31
32
33        option_as_alt = "OnlyLeft";
34      };
35
36      font = fontConfig;
37      cursor.style = "Beam";
38
39
40      colors = {
41        primary = {
42          background = "0xf4f4f4";
43          foreground = "0x676767";
44        };
45        normal = {
46          black = "0xf4f4f4";
47          red = "0xdb7070";
48          green = "0x7c9f4b";
49          yellow = "0xd69822";
50          blue = "0x6587bf";
51          magenta = "0xb870ce";
52          cyan = "0x509c93";
53          white = "0x676767";
54        };
55        bright = {
56          black = "0xaaaaaa";
57          red = "0xc66666";
58          green = "0x6d8b42";
59          yellow = "0xe7e7e7";
60          blue = "0x8a8a8a";
61          magenta = "0xa262b5";
62          cyan = "0x43827b";
63          white = "0x525252";
64        };
65      };
66
67    };
68  };
69}