all repos — dotfiles @ e0d420bc317685f63d129fb25ef02dd44d52259d

my *nix dotfiles

programs/common.nix (view raw)

 1{ config
 2, pkgs
 3, self
 4, ...
 5}:
 6
 7{
 8
 9  imports = [
10    ./git.nix
11    ./tmux.nix
12    ./readline.nix
13    ./neovim.nix
14    ./bash.nix
15    ./ssh.nix
16  ];
17
18  programs = {
19    home-manager.enable = true;
20    direnv = {
21      enable = true;
22      enableBashIntegration = true;
23      nix-direnv = {
24        enable = true;
25      };
26    };
27    zoxide = {
28      enable = true;
29      enableBashIntegration = true;
30    };
31    htop = {
32      enable = true;
33      settings.color_scheme = 1;
34    };
35  };
36}