all repos — dotfiles @ f2509758433000541a38cdd0cb3a23ff040743fc

my *nix dotfiles

nix/services/default.nix (view raw)

 1{ config
 2, pkgs
 3, theme
 4, ...
 5}:
 6
 7{
 8
 9  imports = [
10    ./dunst.nix
11    ./picom.nix
12    ./redshift.nix
13    ./sxhkd.nix
14    ./mbsync.nix
15  ];
16
17  services = {
18    gpg-agent = {
19      enable = true;
20      defaultCacheTtl = 60 * 60 * 24 * 7;
21      maxCacheTtl = 60 * 60 * 24 * 7;
22      pinentryFlavor = "curses";
23    };
24  };
25
26}