all repos — dotfiles @ f32f507400d14c2fbaac570b600beaef602ad56a

my *nix dotfiles

nix/home.nix (view raw)

 1{ config
 2, pkgs
 3, theme
 4, self
 5, ...
 6}:
 7
 8{
 9
10  imports = [
11    ./programs
12    ./services
13    ./x
14  ];
15
16  home.stateVersion = "21.05";
17  home.username = "icy";
18  home.homeDirectory = "/home/icy";
19  home.extraOutputsToInstall = [ "man" ];
20  home.packages = with pkgs; [
21
22    git
23    unzip
24    curl
25    tmux
26    weechat
27    firefox
28    xclip
29    ripgrep
30    arandr
31    imagemagick
32    ffmpeg
33    wget
34    tree
35    mpv
36    w3m
37    noto-fonts-emoji
38    jq
39    yq
40    sxiv
41    st
42    fzy
43    xorg.xmodmap
44    kubectl
45    slack
46    nixpkgs-fmt
47    libnotify
48    signal-desktop
49
50  ] ++ (import ./bin { inherit pkgs theme; });
51
52  xdg = {
53    userDirs = {
54      enable = true;
55      desktop = "\$HOME/desktop";
56      documents = "\$HOME/docs";
57      download = "\$HOME/downloads";
58      pictures = "\$HOME/pics";
59      videos = "\$HOME/vids";
60    };
61  };
62
63  xsession = {
64    enable = true;
65    windowManager.command = "cwm";
66    initExtra = ''
67      xrdb -load $HOME/.Xresources
68      xmodmap $HOME/.xmodmap
69      bar &
70    '';
71  };
72
73}