all repos — dotfiles @ fd4843d30bcb21c74063fa75e4339897a70f628d

my *nix dotfiles

hosts/denna/hardware-configuration.nix (view raw)

 1# Do not modify this file!  It was generated by ‘nixos-generate-config’
 2# and may be overwritten by future invocations.  Please make changes
 3# to /etc/nixos/configuration.nix instead.
 4{ config, lib, pkgs, modulesPath, ... }:
 5
 6{
 7  imports =
 8    [
 9      (modulesPath + "/installer/scan/not-detected.nix")
10    ];
11
12  boot.initrd.availableKernelModules = [ "xhci_pci" "usbhid" "usb_storage" "sd_mod" "sdhci_pci" ];
13  boot.initrd.kernelModules = [ ];
14  boot.kernelModules = [ "kvm-intel" ];
15  boot.extraModulePackages = [ ];
16
17  fileSystems."/" =
18    {
19      device = "/dev/disk/by-uuid/92a27eb2-9814-48fd-8f76-cc152d5a8700";
20      fsType = "ext4";
21    };
22
23  fileSystems."/boot" =
24    {
25      device = "/dev/disk/by-uuid/219A-16D2";
26      fsType = "vfat";
27      options = [ "fmask=0022" "dmask=0022" ];
28    };
29
30  swapDevices = [ ];
31
32  # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
33  # (the default) this is the recommended approach. When using systemd-networkd it's
34  # still possible to use this option, but it's recommended to use it in conjunction
35  # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
36  networking.useDHCP = lib.mkDefault true;
37  # networking.interfaces.enp0s20f0u3u1u2.useDHCP = lib.mkDefault true;
38  # networking.interfaces.enp1s0.useDHCP = lib.mkDefault true;
39  # networking.interfaces.wlp0s20f3.useDHCP = lib.mkDefault true;
40
41  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
42  hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
43}
44