hosts/iso/hardware-configuration.nix (view raw)
1# Do not modify this file! It was generated by ‘nixos-generate-config’
2# and may be overwritten by future invocations. Please make changes
3# to /etc/nixos/configuration.nix instead.
4{ config, lib, pkgs, modulesPath, ... }:
5
6{
7 imports =
8 [
9 (modulesPath + "/installer/scan/not-detected.nix")
10 ];
11
12 boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "usb_storage" "sd_mod" ];
13 boot.initrd.kernelModules = [ ];
14 boot.kernelModules = [ ];
15 boot.extraModulePackages = [ ];
16
17 fileSystems."/" =
18 {
19 device = "/dev/disk/by-uuid/355bf4cf-648a-4c43-8741-ac1804e2d31a";
20 fsType = "ext4";
21 };
22
23 fileSystems."/boot" =
24 {
25 device = "/dev/disk/by-uuid/4E8B-13EC";
26 fsType = "vfat";
27 options = [ "fmask=0077" "dmask=0077" ];
28 };
29
30 swapDevices =
31 [{ device = "/dev/disk/by-uuid/c056b71a-e6eb-49ca-a137-3a24d9e299d9"; }];
32
33 # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
34 # (the default) this is the recommended approach. When using systemd-networkd it's
35 # still possible to use this option, but it's recommended to use it in conjunction
36 # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
37 networking.useDHCP = lib.mkDefault true;
38 # networking.interfaces.eno1.useDHCP = lib.mkDefault true;
39
40 nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
41 hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
42}
43