flake.nix (view raw)
1{
2 description = "a fast and minimal static site generator";
3
4 inputs =
5 {
6 nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
7 flake-utils.url = "github:numtide/flake-utils";
8 gomod2nix.url = "github:nix-community/gomod2nix";
9 };
10
11 outputs = { self, nixpkgs, flake-utils, gomod2nix }:
12 (flake-utils.lib.eachDefaultSystem
13 (system:
14 let
15 pkgs = import nixpkgs {
16 inherit system;
17 overlays = [ gomod2nix.overlays.default ];
18 };
19
20 in
21 {
22 packages.default = pkgs.callPackage ./. { };
23 devShells.default = import ./shell.nix { inherit pkgs; };
24 })
25 );
26}