all repos — vite @ bce0b549b8c10271ee7df30d6d7c78af2675cf6c

a fast (this time, actually) and minimal static site generator

default.nix (view raw)

 1{ pkgs ? (
 2    let
 3      inherit (builtins) fetchTree fromJSON readFile;
 4      inherit ((fromJSON (readFile ./flake.lock)).nodes) nixpkgs gomod2nix;
 5    in
 6    import (fetchTree nixpkgs.locked) {
 7      overlays = [
 8        (import "${fetchTree gomod2nix.locked}/overlay.nix")
 9      ];
10    }
11  )
12}:
13
14pkgs.buildGoApplication {
15  pname = "vite";
16  version = "0.1";
17  pwd = ./.;
18  src = ./.;
19  modules = ./gomod2nix.toml;
20}